Resolved: “Playgrounds targeting OS X are not supported in this version of Xcode.”

Was working through some tutorials at www.raywenderlich.com when I encountered this error when trying to open the provided playground file in Xcode:

nn

Playgrounds targeting OS X are not supported in this version of Xcode.

nn

Google returned only a few results when searching for this error, but one did contain the resolution. I’m posting here so it is forever locatable on the internet.

nn

    n

  1. n

    Right-click on the playground file in Finder. Select Show Package Contents 

    n

  2. n

  3. n

    Open the contents.xcplayground file with any basic text editor (e.g. TextEdit)

    n

  4. n

  5. n

    Change the line

    nn nnnn

  6. n

n

to

nn

<playground version='3.0' sdk='iphonesimulator'>n

nn

    n

  1. Save and close
  2. n

Leave a Reply

Your email address will not be published. Required fields are marked *